Solved

Error: At least one document is required

  • 10 May 2024
  • 5 replies
  • 41 views

Badge +1

Hi,

I am using DocuSign Apps Launcher version 6.4 in Salesforce and CPQ. I have configured the app and users as per the document. 

In the add document configuration, I have selected “Attach Documents from Salesforce record”. I am selecting a record with files and click the “Send DocuSign” button. I get an error “At least one document is required”. 

What am I missing?

 

icon

Best answer by YKay 21 May 2024, 16:16

View Original

5 replies

Userlevel 3
Badge +7

Hey YKay,

Welcome to the community, when you enable the “ attach document from Salesforce record’.  You need to specify the “Document Selection” option.

And it has to be required the open record in salesforce.

 

Pawan Gangwani (He/Him)

Delivery Analyst, Spaulding Ridge

(851) 691-0115 | Follow me on LinkedIn

 

 

Badge +1

Hi Pawan 

As you can see from the screenshot, I have selected the Document Selection as “Latest Document”.

 

Thanks,

Yusuf

Userlevel 3
Badge +7

Then you have to check that “is there any record open or not”.

Badge +1

I found the solution. The issue was that Salesforce CPQ creates the quote document on Quote Documents and Notes/Attachments whereas the DocuSign is expecting the document in the Files associated with the Quote.

 

Solution: Create quote documents on Files as well 

How: Enable “Post to Feed”

Steps:

Enable Chatter on your quote objects

  1. Navigate to Setup | Feature Setting | Chatter | Feed Tracking
  2. Choose Quote.
  3. Click the Enable Feed Tracking checkbox.
  4. Click Save.


Change Where the Quote Document is Attached

  1. Navigate to Setup | Installed Packages.
  2. Click Configure next to your Salesforce CPQ Installed Package.
  3. Locate the Document tab.
  4. Choose Quote as the Attachment Target.
  5. Click the Post to Feed? checkbox.
  6. Click Save.

 

Link: https://help.salesforce.com/s/articleView?id=000380561&type=1

Userlevel 3
Badge +7

wow great ! I appreciate that you stating the solution for this issue.👍🏻

Reply