Solved

SMS Authentication not being sent out when testing with SDK


Userlevel 4
Badge +6

I am using the SDK provided by DocuSign. I am instantiating a RecipientSMSAuthentication object and adding one phone number to the list. When I send the document through DocuSign, the recipient is not receiving a SMS for authentication.

How can I enable SMS authentication? I've verified that the settings are configured correctly on the Admin portal. Is this something not available when using the demo environment perhaps?

Appreciate any help, thank you

icon

Best answer by Community Expert 30 May 2019, 09:18

View Original

8 replies

Userlevel 3

Szymon,

I need a bit more information to help.

To be clear, the way the DocuSign SMS Authentication works is that the recipient first receives an email. The recipient then follows the link from the email to start review of their document. However, given they are on SMS Auth, they are presented with a screen asking them to authenticate via SMS before being able to review and sign docs. They agree and press the necessary button for the system to send out the SMS.

Can you clarify what part of this process is failing?

I'm happy to help once I know more.

Take care,

Arash Sayadi

arash.sayadi@valteotech.com

Userlevel 3

Thank you for the clarification on the SMS authentication process.

The bit for me that is failing is that when I send out a document for signing, I then receive the email to sign the document. Upon clicking the link to sign the document I do not get prompted for SMS authentication and get taken straight to the signing document page. I've done multiple tests and it's the same process over and over.

Did I perhaps miss something when setting up the SMS authentication?

Userlevel 3

Szymon,

Assuming you are both the sender and the recipient in your example, then what you're seeing is expected behavior given you're a known/authenticated user via login.

So, I suggest sending it to a test email on gmail or some other free service that you can check.

Let me know what happens.

Take care,

Arash Sayadi

arash.sayadi@valteotech.com

Userlevel 3

Hi Arash,

I changed the recipient to be someone else.

The recipient is a colleague who has never before interacted with DocuSign before. When he clicked on the email to sign the document, he got navigated straight to the document signing page without being prompted for a OTP even though he should've received a OTP for signing the document.

Kind regards,

Szymon

Userlevel 3

@Arash Sayadi​ Should we expect SMS authentication to work from the dev sandbox?

As per the developer guide

https://support.docusign.com/guides/ndse-user-guide-recipient-authentication

Note: SMS Authentication incurs a per use fee. This option is not available if disabled in your account's Recipient Security settings. See your account administrator for details.

From within the admin portal on the dev sandbox I can't find the setting being refereed to?

Userlevel 3

Folks,

I'm sorry for my late response. I've been heads down on a few gigs.

@Szymon Welgus​ It should have still worked for your buddy. I think Ryano has hit on something though.

@Rayno Jacobs​ The cost per use for SMS is valid in Production, but doesn't apply in Demo. I have mine setup and it works.

To test whether you have SMS available, login to your Sandbox DocuSign Account and try sending an Envelope manually. Be sure to choose the SMS authentication for your recipient when you are defining his/her name and email. It'll be from the dropdown "More > Add access authentication" menu for that recipient.

If it's not available there, then you are right that it's not enabled for your account.

If that's what you find, then you should contact DocuSign Support or your Account Manager to get the feature enabled in your Sandbox.

I hope that helps.

Take care,

Arash Sayadi

arash.sayadi@valteotech.com

Userlevel 1
Badge +12

Hi Arash,

This has been resolved. We did not set two properties when constructing the request for DocuSign. Setting these properties finally got us the behavior you described above.

For closure, the two properties were: RequireIdLookup and IdCheckConfigurationName.

Thank you for your assistance.

Kind regards,

Szymon

Userlevel 3

Great find, Szymon!

Congrats on getting it done.

Arash

Reply